Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Customer Portal Error
#11
Morning Joe,

This is the path variable set in the CP config for CoreBOS app.
$evocp_Server_Path = "https://xxxx:4443";

That is the correct URL as it's the one I use to get to the application/site on my server. I have a redirect in place in the apache config that redirects port 80 requests to http://xxxx. They get redirected to https://xxxx:4443.
Mark

If I could work while on horseback that's where I'd be doing it. There's nothing like riding... Gives new meaning to the phrase, ride to live... live to ride.
Reply
#12
and the user and accesskey are correct I suppose

as you can see in the video there is nothing more to it

maybe the port has something to do with the error, not sure.. would have to debug the code.
Joe
TSolucio
Reply
#13
which part of the log properties needs to be enabled for this?
Mark

If I could work while on horseback that's where I'd be doing it. There's nothing like riding... Gives new meaning to the phrase, ride to live... live to ride.
Reply
#14
is there information in protected/runtime/application.log

maybe activating protected/config/main.php there is a "debug" entry there
Joe
TSolucio
Reply
#15
this is what appears there when I attempt to log into the customer portal:

2019/08/02 12:02:39 [error] [exception.CHttpException.550] exception 'CHttpException' with message 'Customer Portal is not correctly configured.<br/>Please contact your application administrator.' in /var/www/html/apps/coreboscp/protected/extensions/VTActiveResource/VTActiveResource.php:782
Stack trace:
#0 /var/www/html/apps/coreboscp/protected/extensions/VTActiveResource/VTActiveResource.php(726): VTActiveResource::loginREST()
#1 /var/www/html/apps/coreboscp/protected/extensions/VTActiveResource/VTActiveResource.php(735): VTActiveResource->setClientVtiger(NULL)
#2 /var/www/html/apps/coreboscp/protected/components/User.php(71): VTActiveResource->getClientVtiger()
#3 /var/www/html/apps/coreboscp/protected/components/UserIdentity.php(54): User->findByAttributes(Array)
#4 /var/www/html/apps/coreboscp/protected/models/LoginForm.php(65): UserIdentity->authenticate()
#5 /var/www/html/apps/coreboscp/yii/validators/CInlineValidator.php(43): LoginForm->authenticate('password', Array)
#6 /var/www/html/apps/coreboscp/yii/validators/CValidator.php(214): CInlineValidator->validateAttribute(Object(LoginForm), 'password')
#7 /var/www/html/apps/coreboscp/yii/base/CModel.php(158): CValidator->validate(Object(LoginForm), NULL)
#8 /var/www/html/apps/coreboscp/protected/controllers/SiteController.php(228): CModel->validate()
#9 /var/www/html/apps/coreboscp/yii/web/actions/CInlineAction.php(50): SiteController->actionLogin()
#10 /var/www/html/apps/coreboscp/yii/web/CController.php(309): CInlineAction->runWithParams(Array)
#11 /var/www/html/apps/coreboscp/yii/web/filters/CFilterChain.php(134): CController->runAction(Object(CInlineAction))
#12 /var/www/html/apps/coreboscp/yii/web/filters/CFilter.php(41): CFilterChain->run()
#13 /var/www/html/apps/coreboscp/yii/web/CController.php(1146): CFilter->filter(Object(CFilterChain))
#14 /var/www/html/apps/coreboscp/yii/web/filters/CInlineFilter.php(59): CController->filterAccessControl(Object(CFilterChain))
#15 /var/www/html/apps/coreboscp/yii/web/filters/CFilterChain.php(131): CInlineFilter->filter(Object(CFilterChain))
#16 /var/www/html/apps/coreboscp/yii/web/CController.php(292): CFilterChain->run()
#17 /var/www/html/apps/coreboscp/yii/web/CController.php(266): CController->runActionWithFilters(Object(CInlineAction), Array)
#18 /var/www/html/apps/coreboscp/yii/web/CWebApplication.php(283): CController->run('login')
#19 /var/www/html/apps/coreboscp/yii/web/CWebApplication.php(142): CWebApplication->runController('site/login')
#20 /var/www/html/apps/coreboscp/yii/base/CApplication.php(162): CWebApplication->processRequest()
#21 /var/www/html/apps/coreboscp/index.php(89): CApplication->run()
#22 {main}
REQUEST_URI=/index.php/site/login
HTTP_REFERER=https://vtcp.scratchinmyhead.com:4443/site/login
Mark

If I could work while on horseback that's where I'd be doing it. There's nothing like riding... Gives new meaning to the phrase, ride to live... live to ride.
Reply
#16
This tells me that the customer portal cannot login to the corebos application
That means that one or more of the three variables in PortalConfig.php are incorrect. Since we discarded the URL, and I suppose that the username is obvious, the question is:

are you using the Access Key of the user ?

If you are (which I suppose you are at this point) the problem must be with the port, although I vaguely remember having tried this in the past, I'd say that is the issue.

You could try copying this project to a directory next to your customer portal: https://github.com/tsolucio/coreBOSwsDevelopment

that will permit you to test the web service interface of your corebos, at least validate that you can login and query
Joe
TSolucio
Reply
#17
(08-02-2019, 08:11 PM)joebordes Wrote: This tells me that the customer portal cannot login to the corebos application
That means that one or more of the three variables in PortalConfig.php are incorrect. Since we discarded the URL, and I suppose that the username is obvious, the question is:

are you using the Access Key of the user ?

If you are (which I suppose you are at this point) the problem must be with the port, although I vaguely remember having tried this in the past, I'd say that is the issue.

You could try copying this project to a directory next to your customer portal: https://github.com/tsolucio/coreBOSwsDevelopment

that will permit you to test the web service interface of your corebos, at least validate that you can login and query

Interesting... Tried both the portal user and my user (with both access key and password). For a second something flashes on the screen that looks like information in text fields then goes away and I see this on the screen: There is an error with the validation data given, please review and try again.
Mark

If I could work while on horseback that's where I'd be doing it. There's nothing like riding... Gives new meaning to the phrase, ride to live... live to ride.
Reply
#18
Upgrading PHP from 5.4 to 7.0 did the trick. Customer portal is working now. Only one web site is broken but I should be able to recover that one easily enough.
Mark

If I could work while on horseback that's where I'd be doing it. There's nothing like riding... Gives new meaning to the phrase, ride to live... live to ride.
Reply
#19
Smile
Joe
TSolucio
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)