Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Calendar4 You error when linking to google
#1
Dear Users I recieved this error when trying to integrate the Calendar 4 you to my google account

Any help would be apprciated, Thanks

Peter

400. That’s an error.

Error: invalid_request

Invalid parameter value for redirect_uri: Uri must consist of printable ASCII characters: http://www.myservetech.com/apps/wmta/crm/sync.php

Learn more
Request Details

scope=https://www.googleapis.com/auth/calendar https://www.googleapis.com/auth/calendar.readonly
response_type=code
access_type=offline
redirect_uri=http://www.myservetech.com/apps/wmta/crm/sync.php
approval_prompt=auto
client_id=312824214516-jd4hn15k8plkieia2o4o7fpb8gi0lps0.apps.googleuserconte
Reply
#2
Hi Peter.
What part of this tutorial you got this error?

http://corebos.org/documentation/doku.php?id=en:calendar_google_integration#configuring_your_connection_with_google_calendar

I need more info to know the steps that you follow to try to help you?
Reply
#3
Omar Thanks

The error is coming up when I try to 'Authorize and Connect'
Reply
#4
When you create the Api key and the Client ID, have you all the data that I mentioned in the tutorial?
The url http://www.myservetech.com/apps/wmta/crm/sync.php for redirect is important.

You can try to check if all the data in you google console developer is ok, got to Permission menu and delete the permission for your user if exist, and finally got to corebos ->calenar4you -> settings and write the data again.
Reply
#5
Here is what is in my calendar settings


Google authentication for user "Administrator"

Authorize and Connect

Client Secret:
Api Key:
ClientID:
Redirect URI: http://www.myservetech.com/apps/wmta/crm/sync.php
Insert from Google?
Reply
#6
Also Getting this error when trying to set authorization.

My site is located at.
http://www.myservetech.com/apps/wmta/crm

and I cant seem to put that in the upper box

Found that I do not get the 404 error if the link to the sync.php folder is an https:// link

However I get this result when accepting the permissions for Google to access my calendars


Attached Files Thumbnail(s)
       
Reply
#7
In Origin URIs you have to write http://www.myservetech.com
and in Redirect URIs -> http://www.myservetech.com/apps/wmta/crm/sync.php

After in your calendar user settings you have to write the same url in redirect url -> http://www.myservetech.com/apps/wmta/crm/sync.php


Try with this, please.
Reply
#8
Calendar sync seems to be working

However the times are off

When an event was synced form corebos to google the time was off by 4 hours.

Any thoughts on how this could be happening?

Peter
Reply
#9
Did you checked if the coreBOS user time zone is correct?
Reply
#10
Where would I check that? the local time is right

That was it it seems to be working Smile

Thanks
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)