Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Server SMTP Setting
#1
I have a new SMTP server and tried do setting in my coreBOS

I config smtp server name and selected a TLS with Certificate Validantion

But not worked

In log, at debug active, system try do connect port 25 ( not correct in 587 / 465 for TLS protocol )


See log details
===========

2018-03-07T12:03:33-03:00 FATAL index Connection failed. Error #2: stream_socket_client(): unable to connect to smtplw.com.br:25 (Connection timed out) [/usr/share/coreBOS/corebos-master/modules/Emails/class.smtp.php line 299]
2018-03-07T12:03:33-03:00 FATAL index SMTP ERROR: Failed to connect to server: Connection timed out (110)
2018-03-07T12:03:33-03:00 FATAL index SMTP connect() failed. https://github.com/PHPMailer/PHPMailer/wiki/Troubleshooting
2018-03-07T12:03:33-03:00 DEBUG index Error in Mail Sending : Error log = 'SMTP connect() failed. https://github.com/PHPMailer/PHPMailer/wiki/Troubleshooting'


Port 25 ??

Server not accept port 25

I tried put a server_name:587, server_name:465 but still not working.

Always system sent server_name with port 25
Ranieri
eCRM Web
Reply
#2
How I can use TLS with port 587?

I know Gmail uses

TLS in 465
SSL in 587

But my server need TLS in 587 port

Sad
Ranieri
eCRM Web
Reply
#3
http://corebos.org/documentation/doku.php?id=en:adminmanual:outgoingserver

look at the comment on gmail and exchange: you can add your port after the host name
Joe
TSolucio
Reply
#4
I did see that, but when I search in log, system still try to connect at port 25

If I change, in 'hard code', 25 to 587, works.

I tried servername:587 and select a protocol in dropdown list
Ranieri
eCRM Web
Reply
#5
I do this every other day, it is working for sure. Review the settings and the log, the error you are running into has to be there somewhere.
Joe
TSolucio
Reply
#6
Note, the relay support. Many servers do not accept that. I have plans of eliminating this requirement going forward.

Also, leave the "from" address empty, that helps sometimes.
Joe
TSolucio
Reply
#7
But you should be include a tls or ssl after server name

Here my changes

(03-08-2018, 08:36 AM)joebordes Wrote: I do this every other day, it is working for sure. Review the settings and the log, the error you are running into has to be there somewhere.

Yes, you are right.

I need redo a ca.cert certificate too.


Attached Files
.php   class.phpmailer.php (Size: 143.6 KB / Downloads: 1)
.php   class.smtp.php (Size: 42.48 KB / Downloads: 1)
Ranieri
eCRM Web
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)