Full Version: Error in report for tasks - basics filter - data
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I created a new report for Tasks, and choose a basics filter, TODAY. but system not listed any data.

Manually I can listed register for TODAY if I input the data in format dd-mm-yy hh:mm
I just tried and it worked correctly. Make sure you are using the correct start date field.
If you are activate the DEBUG_LISTQUERY global variable and share the SQL with us.
I use Today, not inform any start date

I use a standard filter

In online demo not working too
Ok, I reproduced it, it happens when you add the "send reminder" field, it seems the problem is not related to the filter conditions.

I will have a look as soon as I can.

But I not add send reminder filed ...

This occurs in other parts of system, like as advanced search in filters, single filters ...

Because if you try select a especific registry you need to know, date + hours for especification in search field ...

Example, imagine you need search a specific registry in Tasks for a single user. For example task completed today. This is a problem because you need know exactly a hour registry in task for input in search filed

Date = dd-mm-yyyy not returned anythyng
You need put Date = dd-mm-yyyy hh:mm

It's turned search very complicated
This should fix the send reminder issue.

when you select "today" the query that is constructed has the condition "between today 00:00:00 and today 23:59:00", activate the debug query and you will see it.

this is the condition I see in my tests:

WHERE vtiger_activity.activityid > 0 AND vtiger_crmentity.deleted=0 and vtiger_activity.dtstart between '2018-09-30 00:00:00' and '2018-09-30 23:59:00'
BTW, I set the condition to "tomorrow", that is why it is 30 and not 29