Full Version: [ solved ] Error on workflows task after last updated
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I updated my system today and many workflows shows a error message


Undefined property: VTUpdateFieldsTask::$launchrelwf in /usr/share/master/Smarty/templates_c/f3efcb76b73bacff1a7b82e1d9dcfe3d71b121ed_0.file.VTUpdateFieldsTask.tpl.php on line 85
/>  Launch workflows on related updates

Notice: Undefined index: workflow_id in /usr/share/emaster/modules/com_vtiger_workflow/edittask.php on line 43

Notice: Undefined index: task_type in /usr/share/master/modules/com_vtiger_workflow/edittask.php on line 44

Warning: require_once(/usr/share/master/include/htmlpurifier/library): failed to open stream: Success in /usr/share/master/modules/com_vtiger_workflow/ on line 152

Fatal error: require_once(): Failed opening required '' (include_path='/usr/share/master/include/htmlpurifier/library:.:/usr/share/pear:/usr/share/php') in /usr/share/master/modules/com_vtiger_workflow/ on line 152
I can't reproduce. I even updated the two online demo sites and they seem to be working also.
Make sure you merged correctly
in workflow details (summary list) error occurs, even I try removed a workflow task with error

The requested URL /<br /> <b>Notice</b>: Undefined property: stdClass::$id in <b>/usr/share/master/Smarty/templates_c/dd2a9e5625156df4847183550f07f6312ab52166_0.file.TaskSummaryList.tpl.php</b> on line <b>157</b><br />index.php was not found on this server.

But I can remove all workflows in general workflow list
The issue was with a corrupted workflowtask serialization. I don't know why that happened, we tried the upgrade in half a dozen other installs with no issues. If anyone runs into this again look for me
I solved removed the entire workflow and redo all tasks, again.

thanks for your support