Full Version: Big problem saving sales orders
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I discovered this just now: I can't modify sales orders. When I create one, the status will be "created". Then when I try and change the status, it will be "Approved", no matter which status I choose. And when I try to change let's say, the recurring invoice frequency, it will stay empty. Lastly, I tried mass-editing a couple of sales orders, which led to all SO's being the status "approved" and worse: ALL products and services were overwritten with the products and services of the last one.
That does sounds very bad.
I just tried to reproduce this in the online demo but couldn't. Is this happening on all your installs? What commit version are you on?
Activate debug log, maybe you are getting some SQL errors.
Do you have mappings or global variables?
Maybe a misbehaving workflow? Deactivate all workflows associated to SO and try again.
Pfew, it seems it was a misbehaving workflow, one of which I forgot I installed.. Sorry for the false alarm.. This is my own install, which I use for my own business. Apart from theme development and some HTML and CSS updates I generally don't install experiments like this here, but it seems this time I did. Please check the github version though, since you accepted my PR for generating invoices from workflows it could be this is the problem. I recently updated my install to the latest github version.

Yes, I think my fear is true: the defect workflow has also created some rogue invoices. Again, please check the master repo on github, it may be on there as well!
Which workflow is this? Can you upload a screen shot so I can reproduce and fix?
It's this PR. I thought you altered it before you accepted, but now it's in there anyway. I created an install script through cbupdater in "modules/cbupdater/cbupdates/createWFInvoiceFromSO.xml". It shouldn't be functioning in installs that haven't set it up, and I'm not even sure it's in there but it's worth a second check I think. It;s still possible I tested this workflow in my install only and forgot.
I accepted your PR and then modified it to accept conversion among all inventory modules. Look at the commits on the 22nd Aug

Are you using that version? Is that the one that is failing? Can you reproduce your problem in the online demo or give me steps to reproduce so we can fix it?
Just checked the DB for the workflow task name, but this is "CBXCreateInvFromSO", one I probably never included in the branch. I guess I tested this in my install (something I normally don't do) and forgot about. I think the chances of it being in the Github repo is VERY small.