Full Version: MariaDB install error
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I try install coreBOS in CentOS 7 with mariaDB but install showed

10.1.18 -> MySQL version is not supported, kindly connect to MySQL 4.1.x or above
Try this patch:

that will deactivate the version check and permit you to continue the install.

Note that I have not tried this so I don't know if it will work. I am very interested in doing it. So please share your results with me. I will help you get it working and ask you to do some tests for us. If it works I will change the application to permit this directly.
diff --git a/include/install/resources/utils.php b/include/install/resources/utils.php
diff: unrecognized option '--git'
diff: Try `diff --help' for more information.
Just add the two lines.

The correct command is:

patch -p 1 < deactivatemysqlcheck.diff
This is the correct fix:

I tried it and it seems to be working correctly. The install went correctly and I did some navigating around. Please grab the latest version of the code and try again when you can and let me know how it goes.

I will try again, and post that results, at soon