Full Version: Product lines disappear in salesorders when Quote is selected afterwards
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
When a sales order is created and a quote is selected in editview/createview, the productlines are filled/overwritten. But when you save they're gone. When you create a SalesOrder from a quote and save there's no problem.
I tried this on my local install and in the online demo and in both the product lines were saved correctly. Can you reproduce it in the online demo? Maybe it is associated with normal users (I tested with admin user)?

BTW, I didn't know we had this functionality. Nice!
I don't think I can reproduce this, since it also happened when I tried it (and I'm also admin). Weird thing is, I don't remember hacking anything into SalesOrders (apart from the custom validation). Let me try in a backup install and see what happens. I'll also try and retrace my steps, since I keep a separate repo that only holds the hacks I've made to this installation.


I have reproduced this in the online demo. Look at "SO5" or follow this link. Look at the productlines, they're empty. Only thing I did was click 'edit', select a different Quote (first clicking 'show all quotes') and then save. Got a white screen, so something went wrong. Clicked back a couple of times, then I got back into the SO, where the productlines where empty.
Is there any news on this?
Sorry I didn't see this one. I think it is because I don't get informed when you edit a post so I didn't see your comment until now. I'll have a look and get back to you asap.
No problem, thanks! Do you need me to re-post the research I've done from the gitter group?
Thanks! Will try and let you know.