Full Version: Change Password Issue
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
In my installation, when the administrator change a user password this problem occurs

When the user first logs in, the screen is duplicated and rollup, down until continually
I think we fixed this one some time ago. I just tried on the latest release and it didn't happen. Is this install up to date?
Yes, i click on apply all in corebos Updater

Is possible check ( in log or another way ) if system was updated correctly ?
Updating coreBOS is a two step process. First you update your code, then you apply coreBOS updater.

In other words, coreBOS updater DOES NOT update your code, it ONLY updates the database. It is your responsibility to update the code. Preferably using git
ah ok ...

I'm not familiar with git

Is there any cake recipe to upgrade the corebos?

You really should use git, it makes everything much easier and you really only need a handful of commands. The general idea is:

- you download corebos using git: git clone
- you update your code: git pull
- you apply database changes: corebos updater

Have a look at this vĂ­deo:

You could try downloading corebos and overwriting all your files. That should work. Please make copies before doing this !!

Let us know how it goes and ask for help as you need.
For new installation worked fine.

But when first installed with unzip files, is there any way to upgrade thru git ?
This is a little more tricky, but not much. The steps are like this:

- get a fresh copy of the project: git clone, let say you name this "uptodatecorebos", so it would be:

git clone uptodatecorebos

- copy from you production install, into this new directory:
user_privileges (overwrite any existing files)
and any non standard modules that you may have:
for example, PDFMaker would require that you copy:
if you have others, then you copy their directories
- now move your production install, let's suppose you have your production install in a directory called "corebos", you would do

mv corebos savemycorebos

- now move the new directory to where the production one was:

mv uptodatecorebos corebos

now you should be able to login and load and apply all the coreBOS updater changesets and have everything up to date and under git version control

Please make a backup of everything before starting

let us know how it goes
Worked, only when I removed SQL Reports module.

(03-06-2017, 09:33 PM)joebordes Wrote: [ -> ]I think we fixed this one some time ago. I just tried on the latest release and it didn't happen. Is this install up to date?

Never mind, in corebos 7 is worked fine ...