Full Version: Best Way to Install from Scratch with all plugins/addons
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
Hello; I intend to use corebos as a interface for a language school reseller.

They are selling package english programs and collecting information from students to be used in school registrations.

So for this purpose I thought core bos would be perfect fit with its already programmed customer portal/crm interface; but couldnt take up the project to an end.

Tried many versions and all versions had different troubles. Now I downloaded the latest version and tried to install it but detail pages are not working again.
My host dont let me change the service variables and it works in Native mode. But set up worked properly and installed the system.

How can I get help about installation of GitHub versions?
I am trying to set it up at a GoDaddy ultimate hosting and dont know all requirements.
Current settings :

allow_url_fopen On
display_errors On
error_reporting ~E_ALL
file_uploads On
include_path .:/opt/alt/php55/usr/share/pear:/opt/alt/php55/usr/share/php
log_errors Off
mail.force_extra_parameters no value
max_execution_time 3000
max_input_time 3000
memory_limit 512M
open_basedir no value
post_max_size 128M
session.save_path /tmp
short_open_tag On
upload_max_filesize 1G
<!-- m --><a class="postlink" href=""> ... =Marketing</a><!-- m -->

None of the detailviews are working...
Even when I upload the current state from GitHub; corebosupdater still updates many files and with current files and my config file system is not working.

Some assistance would be really nice...
I can't log in; need user and password.

I have been looking for some time to write a howto on installing and maintaining code up to date. I will eventually get around to it. In the mean time the easiest is to have shell access and use git command line:

git clone <!-- m --><a class="postlink" href=""></a><!-- m --> {yourdirectory}
make sure your webserver user has enough permissions in the {yourdirectory}
do a normal install
load cbupdater changesets and apply them

from then on it should be:

cd {yourdirectory}
git pull
load cbupdater changesets and apply them
(repeat forever)

Give me access so I can have a look. Check the apache logs to see if you are getting any error that can give us a clue as to what is wrong
We can help you get it working.
User : corebos
Pass : corebos

I am also looking for logs will post soon.
The install seems to be working correctly. I created a lead, ticket, navigated around from here to there.
Everything looks normal.
My required functionalities are:

1-Abilty to capture leads from web forms module.
Sample in: <!-- m --><a class="postlink" href=""></a><!-- m --> (Created with old version) If you fill the form and send it you can see the problem.
Now it is not working. I cant create new forms and use them.
If I try to click Edit button on any web forms; it does nothing.

Detail pages are generally not filled properly if I click Edit.

2-Giving leads(I turn them into Contacts and give them Portal Access) ability to add private documents/info; ability to send tickets, see faqs,
Problem was here in old version; people were able to see each others documents and contacts
and I wasnt able to change visibility options to make everyone private.

As they all generated by lead capture form they all have the same organisation name so they reach each others info. If I leave it blank; it shows all blanks to each other.
The webform error seems rather clear to me:

Quote:You don't have permission to access /modules/Webforms/capture.php on this server.
Server unable to read htaccess file, denying access to be safe

that says that your webserver user cannot access that file and is blocking the request for security.

Accessing webforms inside the application also says that files do not exist. Make sure the modules/Webforms directory is present and it has sufficient permissions

As to the portal access, assigning each contact to it's own account is important as the restrictions are based on contacts and accounts. Our customer portal has a more fine grained privilieges system because it is based on REST. Have you tried this situation on our customer portal?

<!-- m --><a class="postlink" href=""></a><!-- m -->
I just tried this on my local machine and it seems to be working correctly.
Pages: 1 2