Full Version: [solve] Suggest - Hide SMS Button when module is disabled
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I suggest, system not show a SMS Send Button, with SMS Module is disabled.
That is already how it works
Not working.

I tested this, before post here.

Reproduced at  online demo, SMS Notifier is disabled, and all buttons and link, still there
I don't know how that can happen and it seems to be working correctly for me. I cannot reproduce what you indicate in the online demo either. Maybe it has something to do with the initial install. Maybe the module is deactivated but the links are there, so then you have to deactivate it again. I will have a look if that is the case, but it is already working as you suggest.
Yes, thats it.

For default module is set disabled ( in fresh installation ). But buttons still there.

If you,manually, enabled and disabled again, works correctly.

Perhaps, in install, for default, module should be marked on active ...
I fixed this by hiding the SMS options on install. I don't think SMS is a very useful module anymore.
Ok, better this way.