Full Version: IMAP (Webmail Module) not really working
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I've been digging at this for days now. There's no reason or feedback that I can get that would let me know why I can't properly read/access an IMAP account with Mail Manager. While I was digging around today I checked the documentation site here:[]=imap

I set about to go down through my PHP ini file to make sure all variables were set correctly. What I found was some were missing entirely from the ini file. As such there was nothing to set. This started me thinking... Are the docs written for a different version of PHP than what I'm running on CentOS 7 (CentOS Linux release 7.4.1708 (Core))? The I remembered something Joe said about a demo (test) install of CoreBOS he's got running on Mint Linux with PHP 7. Now, I'm really starting to wonder...

At any rate I made all the changes in my ini file I could. Now, Mail Manager makes the connection, shows me how many messages exist in the inbox, but doesn't display any folders. When I connect to my gmail account it shows all the folders but won't show any messages. To connect to my Exchange server via imap, or to the local Linux server I have to choose "other" as the account type.

I guess my question is this: What version of PHP is optimal for normal operation of CoreBOS 7? To be honest if I had to upgrade PHP 5.4.6 to PHP 7 on this CentOS 7 server I wouldn't be crazy about it, but because I depend on CoreBOS so heavily and I really like the application I'd do it. I just need to know if it's necessary or could I add those missing variables to the ini file of the current version of PHP?

Merry Christmas Everyone.
Since installing PHP 7 from the remi repo webmail module now reads sees messages in an IMAP account: whether Exchange or local on the LAMP server. However, when I tested replying to a message I'm getting this error:
Quote:Sorry! Attempt to access restricted file.
We are looking for this file path: modules//.php
We are looking here:
Real file path:
Root dir path: /var/www/html/apps/corebos7/
I'm not quite sure what this means. Anyone?
Sorry...I forgot to add. I had attached the message to the ticket I'm working with on this testing. Opened the message there and tried to reply. Replying from webmail module works normally.
Wow... that PHP 7 upgrade was a total train wreck. Saw changes in CoreBOS, but the upgrade completely broke my wordpress sites. It's been removed and I'm back to PHP 5.4.16. *sigh*

PHP 5.4 should work. The truth is that it is well over End of Life now, and PHP 7.2 was released last month:

That said, the demo is working on PHP 5.4. I tried the email there both on my email server (debian) and on my gmail account and both seemed to work correctly.

I tried also on my development machine which has a 7.0 and it also worked correctly.

The error message above is usually some SQL error somewhere. The easiest way to see that is to activate the debug log and reproduce the error. You should see the failing SQL in the log.

Sorry, I can't be of more help than "it works for me". Maybe you can create a temporary email account and configure it in the online demo so I can reproduce the error. Or send me a temporary email on your server so I can test locally.....
Hi Joe,

There is something not right with php-imap in PHP 5.4.x... (that package isn't in the CentOS repositories. I had to get it from the EPEL Base repo.) The differences in speed and functionality I saw in CoreBOS yesterday when I had it running with PHP 7 were very noticeable. What really twisted my nickers though was the way Wordpress completely broke and they are advocating upgrading to PHP 7 for security reasons. What little I was able to find out while going through all this yesterday was the changes (within PHP) where they've changed from using mysql to mysqli. I first saw this in the CoreBOS 7 file and didn't think much about it at the time, but it's starting to make a lot more sense now. Apparently wordpress has made this change as well and it very well probably had a lot to do with why WP broke yesterday. Even though I'm running the most recent version of the application. 

All in all I figured out yesterday that the webmail module issues I'm experiencing appear to be centered around the version of PHP that is installed on my server. The huge changes I witnessed in CoreBOS yesterday while 7 was installed bear that out. Although I'm still curious as to why, even using PHP 7 I wasn't getting an IMAP folder list; whether connected to my exchange IMAP or local dovecot IMAP connection. I can't even begin to fathom why CentOS 7/Redhat 7 aren't running the latest version of PHP. Especially if PHP 5.4 is EOL! Part of the problems I was having at first getting things to run was because I had to add repositories to Yum in order to install PHP 7. That almost always brings it's own baggage along; none of it any good. The farthest out I feel comfortable going in that area is adding EPEL repos to my CentOS distro. It put a boatload of extra folders for PHP 7 in /etc/opt and then I accidently found that I was missing a package because nothing on the web server worked. As I recall it was a package that contained the necessary php.conf file for Apache: What a mess!

So, since I lack the necessary hardware at the moment to do all this testing, VMWare Player won't run on my workstation, I'm going to have to figure out how to get a VM setup on my workstation to do the necessary testing. If I can get CoreBOS and Wordpress both running on PHP 7 then I'll be able to upgrade. 

Maybe I'm just running the wrong Linux distro...