Fail to upgrade Corebos - Printable Version

+- CoreBOSBB (
+-- Forum: Support (
+--- Forum: Administrator Support (
+--- Thread: Fail to upgrade Corebos (/showthread.php?tid=1709)

Fail to upgrade Corebos - addady2 - 02-14-2020


I'm trying to upgrade from old Corebos ~12/2018 and fail.

git fetch origin

Fix some conflicts and then login in order to finish the upgrade using "corebos updater".
The interface is broken, and I can't use the menu.
I'm using an update Chrome browser.

Allso I try to login from old Firefox, The Interface is still broken but I was able to press on "corebos updater".
No thing happen after pressing.

Attach screenshots

How to fix it?

RE: Fail to upgrade Corebos - joebordes - 02-15-2020

this is because the cache is not loading correctly. it could be "just" a cache issue or that you have some file missing.
the first thing to do is:

- log in to the application
- log out of the application
- close all tabs that may have the application open
- log in again

if it is a cache issue it should be fixed, if it is still not right then look in the chrome inspector, you should see some error about the service worker not being able to load something

as to the corebos updater not doing anything: what does "nothing happen" mean? Do you see a white page? the header with no content? no updates loaded? ...

RE: Fail to upgrade Corebos - addady2 - 02-15-2020

Logout using pre update git branch solve the issue.

Now I run corebos updater. most of the update executed successfully except few:

Quote:Update cbupd-0000253: migrateLinksIntoBusinessActionEntities::migrateLinksIntoBusinessActionEntities

ALTER TABLE `com_vtiger_workflows` ADD `purpose` TEXT NULL;
ALTER TABLE `com_vtiger_workflows` ADD `relatemodule` varchar(100) default NULL;

Update cbupd-0000255: addSummaryColumnToProfile2Field::addSummaryColumnToProfile2Field
ALTER TABLE vtiger_profile2field ADD summary enum('T', 'H','B', 'N') DEFAULT 'B' NOT NULL

Update cbupd-0000259: addWFPurpose::addWFPurpose
ALTER TABLE `com_vtiger_workflows` ADD `purpose` TEXT NULL;

Update cbupd-0000274: addChgPWDEmailTemplate::addChgPWDEmailTemplate
creation of change password email template
Permission to perform the operation is denied

Update cbupd-0000275: migrateemailtemplates::migrateemailtemplates
Migrate EMail templates
Permission to perform the operation is denied

Update cbupd-0000278: emailmsgTemplate::emailmsgTemplate
creation of customer portal email message template
Permission to perform the operation is denied

Update cbupd-0000282: addSendEmailAction2FAQ::addSendEmailAction2FAQ
Add FAQ template and send email action
Permission to perform the operation is denied

Update cbupd-0000300: addCbRuleMissingContext::addCbRuleMissingContext
Add coreBOS Rule web service call missing context
INSERT INTO vtiger_ws_operation_parameters (operationid, name, type, sequence) VALUES (73, 'context', 'String', 2);

How to fit it?
Is the system safe to use?

RE: Fail to upgrade Corebos - joebordes - 02-15-2020

glad that worked, that means that it had been a looong time since your last update, you should update more frequently, no need to be cutting edge, but I would recommend to not make it so long.

Yes, you are ok to use the system. Most of the errors are redundant. They are due to the fact that those changes are mandatory so they are applied at the first chance we get to do so, if they are automatically applied the updates fail, but nothing to worry about.

Anyway, apply them all again to see if the email templates can be created and you can go ahead.