Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Problems upgrading from vtiger 5.2.1
I'm stepping through the install again and documenting the steps. There are some issues with the installer that I want to bring to your attention.

When taking the code from GitHub and copying it over a vtiger 5.2.1 install and then going to /install.php in a browser, when I get to the "Confirm Configuration Settings", it always says: "Unable to connect to database Server. Invalid mySQL Connection Parameters specified"

My workaround, was to edit the file directly with the database credentials.

So, THEN, if I begin the install again, I will get past the page "Confirm Configuration Settings" page and I come to the "Pre-Migration Tools" page and it says: "Your database table engine is not the recommended engine "Innodb". Please make sure to change the engine before migration."

Even though this is not true for my database. AND when I click "View Report", I get: "Required tables were detected to be in proper Engine type (InnoDB).
You can close this window and proceed further with migration."

I click "Next", and I get back to "Confirm Configuration Settings" with the same error message: "Unable to connect to database Server. Invalid mySQL Connection Parameters specified"

BUT THEN, if I click "Change", and then click "Next", and then "Next" again at the "Pre-Migration Tools" screen, I finally get to the "Confirm Configuration Settings" screen and the migration can begin.

I've gone through the install process about 4 times now just to verify the process and the steps above occur EVERY time. I've even upgraded to vtiger 5.3 and then to 5.4 and then to corebos and the same steps occur.

Other Tips that helped me through:
1.) The password set for admin doesn't work after upgrade. Had to do the old vtiger admin password reset trick: UPDATE vtiger_users SET user_password = 'adpexzg3FUZAk', crypt_type='' WHERE id=1;
--> Which resets the password to admin. That got me in.

2.) Update your tables to INNODB through the mysql command line before you do the migration.
Very easy to do: ALTER TABLE tablename ENGINE=InnoDB;

3.) To make the upgrade go faster, disable all the users except for admin:
CREATE TABLE vtiger_users_backup as select * from vtiger_users;
update vtiger_users set status='Inactive',deleted=1 where user_name<>'admin';

Then, after it's done, activate them again:
update vtiger_users inner join vtiger_users_backup on set vtiger_users.status=vtiger_users_backup.status,vtiger_users.deleted=vtiger_users_backup.deleted where vtiger_users.user_name<>'admin';

This cuts down the time to upgrade down to about 5 minutes.

Messages In This Thread
RE: Problems upgrading from vtiger 5.2.1 - gorundown - 05-13-2016, 08:56 PM

Forum Jump:

Users browsing this thread: 1 Guest(s)