Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
CentOS7 VM Corebos File Permissions
#1
Hi All... Happy New Year!

I've been doing some testing using VMs and I ran into something rather strange this morning. I've got a CentOS 7 VM that I'm testing PHP7, Wordpress and Corebos on. I got the basic system config setup and started testing. Wordpress is doing fine. So, the next step was to grab a fresh copy of Corebos from GitHub and run the install. The weird thing I saw was this:

  1. Set file ownership and permissions for the CoreBOS installation (owner apache.apache): Dirs 755 and file perms are set to 644
  2. CoreBOS basic file perms same as those being used by Wordpress apps.
  3. CoreBOS basic file perms same as production server. 
  4. Apache service running as user apache and group apache.
So, I start the install, take care of the PHP requirements on the screen but the install screen is telling me that the file permissions aren't correct. It's telling me the files/directories aren't writable. these are the same permissions I'm using on the production server; also running CentOS 7, with one exception. The production server is running PHP 5.4.16.

Thinking this is a bit strange I chmod config.inc.php to 755 and then hit Check again, but it makes no difference. 

Any idea why it would be complaining about file permissions like this when the only difference between this VM and the production server is the installation/version of PHP?

I also tried setting everything to 777 and got the same results... very strange.
Mark

If I could work while on horseback that's where I'd be doing it. There's nothing like riding... Gives new meaning to the phrase, ride to live... live to ride.
Reply
#2
Check if you have selinux active and deactivate it to try:


Quote:Now you will need to disable your SELinux. To completely disable the SELinux you will need to edit /etc/selinux/config file.

Code:
nano /etc/selinux/config
If you don't have nano installed, you can install it using yum -y install nano Find the following line:
Code:
SELINUX=enforcing
Change it to:
Code:
SELINUX=disabled
Now you will need to reboot your server so that the new configuration can take effect.


If that works, the correct way to do it would be to configure selinux to permit using coreBOS correctly but I don't know how to do that.
Joe
TSolucio
Reply
#3
Happy New Year :-)
Joe
TSolucio
Reply
#4
(01-01-2018, 10:55 AM)joebordes Wrote: Check if you have selinux active and deactivate it to try:



Quote:Now you will need to disable your SELinux. To completely disable the SELinux you will need to edit /etc/selinux/config file.


Code:
nano /etc/selinux/config
If you don't have nano installed, you can install it using yum -y install nano Find the following line:

Code:
SELINUX=enforcing
Change it to:

Code:
SELINUX=disabled
Now you will need to reboot your server so that the new configuration can take effect.


If that works, the correct way to do it would be to configure selinux to permit using coreBOS correctly but I don't know how to do that.

good heavens! you're right. I completely forgot about that. Thank you Joe.
Mark

If I could work while on horseback that's where I'd be doing it. There's nothing like riding... Gives new meaning to the phrase, ride to live... live to ride.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)