Thread Rating:
  • 1 Vote(s) - 4 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Moving Customer Portal to new server - getting error
#1
Grrr. this will the my 3rd attempt at making this post. Damned Backspace key seems to think I want to go back in the browser history for some reason today.


Last week I finally committed to moving from my CentOS 5 server to a new CentOS 7 server. I've got all my Wordpress sites moved and this morning I started all the preparations for moving my CoreBOS installation over.
  1. Moved the database with MySQL admin - check
  2. moved the CoreBOS program directory from old web server to new web server - check
  3. Set ownership and permissions on CoreBOS - check
  4. Setup SSL for Existing certs in Apache config - check
  5. Changed port-forwarding on firewall to send port 4443 traffic to correct server - check
  6. tested CoreBOS: logged in and can work. Everything with CoreBOS is working normally.
Time to move the CP over. Since it looks to the main CoreBOS install and DB for most things, I just moved the directory over and made sure ownership was apache.apache. I believe most perms are 755 down through the tree. Didn't work... Was getting errors on the screen complaining about runtime dirs not existing or not having the right perms. So, I grabbed a fresh copy by cloning what exists on github.

Again, ownership is apache.apache and the directories have a perm setting of 755, (index.php - 644)

Go to the site for my CP and get the login screen. Attempt to log in and see this:
Quote:Internal Server Error

date(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.
An internal error occurred while the Web server was processing your request. Please contact the webmaster to report this problem.
Thank you.
2017-12-06 17:09:23 
notice that the time stamp on this error is about 5 hrs and a few minutes ahead of the actual system time. Not sure why... I'm EST New York (UTC -5:00) is the setting inside CoreBOS.
At the moment I'm out of ideas, so if anyone knows what is going on or could provide a direction or go I'd really appreciate it. 
It's been quite a while since I've installed the customer portal and I don't remember the steps I took last time to get it going. I've been running everything on my old CentOS 5 server. 
A Little Extra Information

  • Server: Linux CentOS 7
  • Apache 2.4
  • PHP 5.4.16
  • MySQL Server: 5.6.38 (and yes, I moved my DBs from 5.0 right to 5.6)
Thanks in advance...
Mark

If I could work while on horseback that's where I'd be doing it. There's nothing like riding... Gives new meaning to the phrase, ride to live... live to ride.
Reply
#2
Hi Mark

Glad to hear coreBOS is working. I had a quick look on the internet for the error and it seems that you have to define a Timezone in your php.ini file:

https://stackoverflow.com/a/16765214/2914970

try that and let me know
Joe
TSolucio
Reply
#3
(12-06-2017, 11:18 PM)joebordes Wrote: Hi Mark

Glad to hear coreBOS is working. I had a quick look on the internet for the error and it seems that you have to define a Timezone in your php.ini file:

https://stackoverflow.com/a/16765214/2914970

try that and let  me know

Joe,

You are a wizard. I guess combined with my lack of time with Linux, and juggling too many things... I feel foolish missing this setting, but thank you very much. Worked like a charm.
Mark

If I could work while on horseback that's where I'd be doing it. There's nothing like riding... Gives new meaning to the phrase, ride to live... live to ride.
Reply
#4
:-)
Joe
TSolucio
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)