Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Time in application 5 hours ahead
#1
UGH! yup... ready to pull out my hair. 

Time zone correct in php.ini file. Checked it a dozen times.

Let me start from where I'm at...
  • I've got corebos 7 and corebos 5 running side-by-side.
  • All my data - at least the data that matters - has been moved over to the C7 installation.
  • create a ticket or anything that displays (uses) a time stamp: the time is correct in C5 whereas the time is 5 hours ahead in C7.
  • thought maybe there was something amiss with config.inc.php file, so I copied over the one from C5... no change.
  • in both config files I've set this line to: $default_timezone = 'UTC -5:00'; (in the past this always worked and in fact is the setting in use by C5 which is running on the same server using the same everything that is installed on this new CentOS7 server.
  • I know it's something stupid and small I'm missing... perhaps more beer will help.
  • I've tried removing the -5:00 from the $feault_timezone variable so that it's value was just 'UTC'. No change.
  • It won't effect the actual time I spend on trouble-tickets, however it kinda matters a lot because, well... it's not right and it's buggin me.
Apart from that and one other thing C7 is running fine.Spent a few hours migrating data over, but not a big deal in the grand scheme of things.

All right, you twisted my arm... These variables don't seem to work at all now:
Code:
// helpdesk support email id and support name (Example: 'support@your_support_domain.tld' and 'your-support name')
$HELPDESK_SUPPORT_EMAIL_ID = 'mweaver@compinfosystems.com';
$HELPDESK_SUPPORT_NAME = 'CISS Support';
$HELPDESK_SUPPORT_EMAIL_REPLY_ID = $HELPDESK_SUPPORT_EMAIL_ID;

Those three lines used to make handle how the emails that went out when a ticket was created, and updated. Now, when they get sent out its "your_name" that appears on the message. Ugh... more beer is definitely required.
Mark

If I could work while on horseback that's where I'd be doing it. There's nothing like riding... Gives new meaning to the phrase, ride to live... live to ride.
Reply
#2
UPDATE: Just cause I was curious I set the time value in config.inc.php to 'UTC +5:00' and it didn't make a difference. I have no idea where it's getting it's timezone information from at this point.
Mark

If I could work while on horseback that's where I'd be doing it. There's nothing like riding... Gives new meaning to the phrase, ride to live... live to ride.
Reply
#3
Timezone:

Set the $default_timezone to UTC, that is the only value that it should have. In fact, I am thinking of eliminating that variable from there completely. Then go to your user preferences and select your timezone. That should be all you need to do. Make sure your admin user also has the correct timezone set. Let me know how it goes.

Variables.

Those variables (and almost all others in config.inc and config.performance) have been moved to Global Variables module. You can define them there. Have a look at config.template.php, that file contains the currently valid variables you should have in your config.inc.php
Joe
TSolucio
Reply
#4
Hi Joe,

Timezone mystery solved.... I knew it would be something I missed. Right in front of me too. Perhaps mid-afternoon naps would help.

Global variables... I can see this is going to be an adventure... and I've already got a pot of dark roast brewing. Geez Joe! you've been busy. It's like getting to know the program all over again. Smile
Mark

If I could work while on horseback that's where I'd be doing it. There's nothing like riding... Gives new meaning to the phrase, ride to live... live to ride.
Reply
#5
:-)
Joe
TSolucio
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)