Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
New mass-edit: is there a record limit?
The old mass-edit could take a long time when you edited many many records. I tried the new mass-edit on 660 records at once, and at one point I stopped to refresh the page after ten minutes. I noticed none of the records had been altered, not even the first couple of pages. Has anything changed in this behaviour? Should I just keep waiting? Is there a fixed record limit here? Maybe, when editing that many records you're better off exporting, changing and importing?

By the way, the old mass-edit also had this: when you select ALL records and press mass-edit, an empty popup appears. I think it's a missing translation, but it's empty so I don't which label to translate.
I think you are having some problem with your install. Probably a fatal error that is breaking the mass edit.
When it works correctly you will start seeing the list of updated records in the popup. Before this change you saw nothing, it just stuck there with no feedback.
I'll check the logs. By the way, 20-40 records DO work just fine (attached screenshot). It's when I edit ALL records (tried on multiple modules to edit 600 or more) that nothing happens. Think the new mass-edit is a good thing, I'll try to debug it.

Tried some more with 100-150 records on different modules. That worked. I'm running one now with over 2000 records and a tail -f on the error log.

Attached Files Image(s)
Just did a test: I installed an untouched, fresh corebos installation (version today 18-7-2018),

mySQL version:
mysql Ver 14.14 Distrib 5.7.22, for Linux (x86_64) using EditLine wrapper

PHP version:
PHP 7.0.30-0ubuntu0.16.04.1 (cli) ( NTS )
Copyright © 1997-2017 The PHP Group
Zend Engine v3.0.0, Copyright © 1998-2017 Zend Technologies
with Zend OPcache v7.0.30-0ubuntu0.16.04.1, Copyright © 1999-2017, by Zend Technologies

Then I imported about 2200 products. I ONLY imported the productname and set the handler to the admin user. Then I selected all records and mass-edited a simple field (I think it was part no.). The mass-editor opened and gave no feedback. After a couple of minutes I checked the first product in another tab, nothing had changed. I also kept a tail -f of the apache error log file open, no fatal errors.It has been running for 4-5 minutes now, no feedback still and the products with the lowest ID's have not been altered yet. If you want I can send you the CSV file of the export.

It's been running for 22 minutes now. No change.

Just opened another tab and selected 200 products. Mass-edited them (set the website to somethingstupid), the editor began to run almost instantly and updated the records in a flash. I checked the JS console in both tabs (the other one is still waiting, nothing happened after 25 minutes). The only thing there is a warning about an insecure operation of the service worker. But that was there in the other tab (where the mass-edit worked) as well.

Think I'm getting at the number that it stalls. I've gone up to 500 records at a time. That all went very quickly (also tried 506). Then I tried 600, nothing happened. To be sure it's not the products, I sorted them the other way around and again selected the first 600. Again, nothing happened.
There is a POST IDs limit. You are getting a javascript error, the process never starts.
We'll look into it as soon as possible.
Frankly I don't think it's the JS error. I thought the same thing at first but then I checked the other tab, that did start the mass-edit: it had the same JS error in the console. Or did you not mean the serviceworker error? I think I remember something now, the max. POST size of javascript like you said. That may very well be the issue yes...
the web worker error, the event source. it does not accept POST parameters so they send in the IDs via GET which is too long
Something more for me to learn..

In the meantime, how about removing the box with the results a few seconds after the mass-edit is complete? Would that be an idea? Right now when I mass-edit, and then see I've missed a record and want to mass-edit that as well, I have to reload the page because otherwise I can't reach the fields on the right side.

Forum Jump:

Users browsing this thread: 1 Guest(s)