Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
How to manage users?
In a fresh CoreBOS install I am trying to manage users from the Settings Panel.

However the link does not help:
leads to

Module name is missing or incorrect. Please check the module name.
Where did the module go?
Execute coreBOS updater. Go to:


click on the "Load" and then on the "Apply All" buttons.

You may have to do that a couple of times.

After all the updates are applied you should be able to go to the users settings page normally

Let me know how it goes.
Hi Joe,

I did all the updates and they ran correctly.

Now the Settings-->Users Link has this underlying link: index.php?module=Administration&action=index&parenttab=Settings

But the result is still a missing module:

Module name is missing or incorrect. Please check the module name.

The install is from a git clone, so it should be complete...?!
Look at this link in the online demo:

You will see that it is not Administration any more.

The changeset that does this change is delAdministration:

make sure you have this one loaded and applied.
Thank you for the answer.
I don't know how to log in to the demo.

When I try to use the url you posted on my install I get the following line:
The record you are trying to view has been deleted. cbupdater: 27251 Go Back.

I will download the complete files once again, try again and let you know...

Have a nice evening.

Well, I am close to giving up.
I uploaded the whole installation once more and now get
"cbupdater module is not active! on almost every page."
But I cannot access the modlues page to avtivate it without getting the same message.
I can't find my way through all these unpredictabilities...
Quite frustrating.
Let me try a new install and get back to you. I'd say it is a problem with permissions, are you sure that you have all the ones indicated in the requirements?

For the demo you have:

user: admin
password: admin

then there are a bunch of other users like, testdmy, testymd, testmdy and some others which all have the same password as their user name (if somebody hasn't changed them)
I'm really sorry you are having problems with the install.

I just did two installs. Both worked with no issues. The first one I had to apply all the pending changesets to get User administration working so I can confirm that your issue is that you need to launch the updates. Then I made some changes to eliminate some warning messages and fix the database driver detection for mysqli and I updated the install database so it now has all the latest changes (you don't have to do the changesets immediately). With those changes the install worked correctly also.

Like I said above I'd say the problem you are having is a lack of permissions on the tabdata.php file, make sure the webserver user can write in that file then go to Module manager and deactivate a module like Assets and activate it again, that will force the application to generate the tabdata.php file and you should be able to get in to the updater.

Maybe this video can help:

Let me know how I can help you.
Thank you Joe,
I already watched the video but it seems the installation did not finish correctly. All databases have been created but the install directory was not renamed. So maybe something went wrong and this is the reason why not everything works like it should work.

But its a little odd because I am using a dedicated server with quite some resources. I could not find any errors in SQL error.log.

I will try a fresh install on a hosted webspace and see how it works there.
I'll get back to you.

Maybe you could advise us to somebody who could get payed to set us up and migrate a database of about 1000 customers and the respective records?

Best regards
Make sure the permissions are correct, I am almost positive this is the source of all your issues.

Please send an email to, me and my team will help you.
Well it seems our server has some issues with the databases. It is a MariaDB server. Is that an issue somehow...?

I managed setting up a new install in a hosted space and migrating the tables step by step. So now I have a clean setup with all our data - just not the server that can deal with it.

I have another issue with the PDFMAker and EMailMaker by ITs4You. I will post another thread for that - tomorrow.

Thank you or your patient help!

Forum Jump:

Users browsing this thread: 1 Guest(s)