Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Email error - when using smtp
#1
Hi,

When am using smtp for sending email, i get the following error when i compose an email for a lead -

The first error that i get is -
Please check the current user mailid.It should be a valid mailid to send Emails

Then, when i add an email manually in the from field, i get the next error -
Warning: Creating default object from empty value in /home/iperac/xyz.com/corebos-master/modules/Webmails/Webmails.php on line 745

I was using sendmail earlier but the emails appear in spam, so i switched to smtp.
What could be the problem here? please help.

thanks,


Attached Files Thumbnail(s)
   
Anil Purushothaman
Reply
#2
Hi,

I resolved the issue myself after a full day effort on smtp code and settings. I found that -

1. Emails can be sent using SMTP.
2. With a gmail account, we have to now use TLS and port is 587.
3. Outgoing server settings no longer require host entry in the form of "ssl://smtp.gmail.com:465", it has to be simply smtp.gmail.com and also note that TLS is used.
4. Direct entry of smtp settings into "vtiger_systems" table also works.

thanks,
Anil
Anil Purushothaman
Reply
#3
Hi,

I was successfully able to send email using "send email" button on Leads list page and email composer window. However, I am not able to send emails now (SMTP activated) through workflows. Workflow emails were working when i was using sendmail. I see that CronTasks module is not activated, does this have anything to do with it? Has anyone tested workflow email using smtp? Please help.

thanks,
Anil
Anil Purushothaman
Reply
#4
Glad you got it working.

I use excluesivly smtp to send emails, I understand that your problem was with the gmail specific requirements.

All emails sent from the system use the same mail functionality, there is no difference in how the email is sent no matter where it is generated. If you workflow emails aren't going out I'd say the problem is with the cron.

In the wiki there is a page describing different issues configuring outgoing emails and how to debug the issue:

<!-- m --><a class="postlink" href="http://corebos.org/documentation/doku.php?id=en:configureoutgoingserver">http://corebos.org/documentation/doku.p ... oingserver</a><!-- m -->

I am going to add your comments on configuring gmail account there also.
Joe
TSolucio
Reply
#5
Thank Joe for your response, if need be I can make a step-by-step guide for smtp setting <!-- sSmile --><img src="{SMILIES_PATH}/icon_e_smile.gif" alt="Smile" title="Smile" /><!-- sSmile -->

Now I need help on correcting the cron task problem. why am i not able to activate the cron tasks module? see attachment.

thanks,


Attached Files Thumbnail(s)
   
Anil Purushothaman
Reply
#6
The typical error for this is that your web server user does not have enough write permission on the tabdata.php file, so it isn't being updated when you activate the module in module manager. First make sure the web server user can totally write to that file in the root of your install and activate the module again in module manager.

Let me know how it goes.
Joe
TSolucio
Reply
#7
BTW, it would be a pleasure to add your step by step guide to the wiki. If you can find some time to do it, send me a copy and I'll translate and upload it.
Joe
TSolucio
Reply
#8
Hi,

I got the cron also almost working i guess.....however, i still do not know how to activate the scheduler, its still the same as in the screenshot before. What i have got running is the vtigercron.php, since its a centos machine i changed PHP_SAPI value from "cli" to "cgi-fcgi" and things started moving.

Now when i run vtigercron.php from command line, i get messages such as - no mail box defined for scanning, or time not completed for executing workflow, etc.

help me !
Anil Purushothaman
Reply
#9
Hi,

I got it all running finally, i modified executecron.sh file and replaced the following code -

#wget http:// localhost:APACHEPORT/cron/ intimateTaskStatus.php -O intimatelog.txt

with my server's path -

wget http:// xyz.com/ corebos/cron/ intimateTaskStatus.php -O intimatelog.txt

i activated the crontasks module from Settings --> module manager --> custom modules.

So its all fine now ! Cheers !!
Anil Purushothaman
Reply
#10
<!-- sSmile --><img src="{SMILIES_PATH}/icon_e_smile.gif" alt="Smile" title="Smile" /><!-- sSmile -->
Joe
TSolucio
Reply


Forum Jump:


Users browsing this thread: 2 Guest(s)