Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Mobile module
I have a problem with the Mobile module theme. When I try to create a record(i tried with tickets and organisations) most of the picklist values only shows an 'A' option. Worst is that 'Assigned to' field does not permit anything to be selected(and it's a mandatory field pretty much everywhere) so when I try to save the record i get 'Permission to perform operation is denied for id'. I attached a screenshot. This is on a fresh instalation. Thank you for the help.

The above behavior shows with php 7.1 - i tried with php 5 and it is ok. Maybe this gives some clues to the module maintainer. Thank you

Attached Files Image(s)
Thanks to report this bug.

Please, let me try a PHP 7.1 to try to reproduce the error.
I'll keep you informed.

Before test it, can you give more information about your setting, if you have any javascript error,...

Hello Omar. The install is on a updated debian 8(simplest install, no other bloat) with apache,mariadb and php 7.1 in a virtualbox machine(but I also tested on real machine). owner of the folder was set as www-data(debian default for web access) and permissions 0755 on all the files inside corebos-master. I created the database before corebos's installer with this: GRANT ALL ON corebos70.* TO 'DBADMINNAME'@'localhost' IDENTIFIED BY 'PASSWORD'; defined at installer to point to but the actual ip address i use is a class c 192.168.0.x so i don't know if that might be an issue. in the php.ini I have the recommended settings, with bigger post and upload sizes. I don't know exactly where to look for javascript errors, I'll do a search to find out where those are reported (i'm not that good at web development). Eventually I can give you access to the machine since it's a test only. Please tell me if there is anything else that I can do to help. Thank you.
Thank you for details.

For open the web console to look javascript errors, first you have to access to Mobile module from your computer. Open Google Chrome or Firefox, go to your coreBOSMobile and open the web console.

On Firefox you can find it from the menu -> Web developer -> web console.
And in Chrome , menu -> Developer tools -> and select console tab.

After that try to reproduce the error and if you see any error on the console, make a screenshot and attach it here, please.
The attached image is correct?
If I edit an already created ticket, when I push save I get this:
Fatal error: Uncaught ArgumentCountError: Too few arguments to function HelpDesk::getUpdateLogEditMessage(), 2 passed in /var/www/html/corebos-master/include/Webservices/Update.php on line 118 and exactly 3 expected in /var/www/html/corebos-master/modules/HelpDesk/HelpDesk.php:435 Stack trace: #0 /var/www/html/corebos-master/include/Webservices/Update.php(118): HelpDesk::getUpdateLogEditMessage('375', Array) #1 /var/www/html/corebos-master/modules/Mobile/api/ws/SaveRecord.php(91): vtws_update(Array, Object(Users)) #2 /var/www/html/corebos-master/modules/Mobile/views/SaveRecord.php(16): crmtogo_WS_SaveRecord->process(Object(crmtogo_API_Request)) #3 /var/www/html/corebos-master/modules/Mobile/index.php(97): crmtogo_UI_ProcessRecordCreation->process(Object(crmtogo_API_Request)) #4 /var/www/html/corebos-master/modules/Mobile/index.php(129): crmtogo_Index_Controller::process(Object(crmtogo_API_Request)) #5 {main} thrown in /var/www/html/corebos-master/modules/HelpDesk/HelpDesk.php on line 435

Attached Files Image(s)

Forum Jump:

Users browsing this thread: 1 Guest(s)