Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Yes, assigned to also
joebordes Wrote:
polanskiman Wrote:In the import file I've only left the contact ID, last name and department. Haven't clicked the import button yet for the following reason:

Is it normal that corebos does not recognize the contact ID header? By not recognize I mean that states --None-- instead of choosing the corresponding CRM field. That would probably be the single most accurate identifier since there is only one per contact. What's up with that?

By the way, thanks I think we are nearly there!!

Please upload a screenshot. I think this may be related with this question I was asked earlier this week:

<!-- m --><a class="postlink" href=""> ... entID_null</a><!-- m -->

In your video it shows the same for the Lead No. It shows "None"
In the video I am not merging on Lead No, in step 3 on the first page I select First and Lastname. If you want to look for duplicates depending on the Lead No, you would select that there, no?
joebordes Wrote:In the video I am not merging on Lead No, in step 3 on the first page I select First and Lastname. If you want to look for duplicates depending on the Lead No, you would select that there, no?

Not sure I am understanding. Whether or not you are merging on Lead No is not the problem. No matter what is selected, the Contact id in the CRM field still shows None. That was my point. For myself I wanted to use the Contact ID as the identifier but it shows None too.
I just tried it and you and Andrea are correct: although you select the ContactID field to do the comparing it doesn't work if it isn't selected again in the mapping. I had never realized that, because I see no relation between the two concepts.
I will open a ticket and fix that, in the mean time, Andrea's solution is perfectly valid:
- create a custom field
- create an update workflow to copy the contactID to the custom field
- merge on the custom field
- eliminate custom field

I'll let you know when I fix the problem
Thanks. Will try that tomorrow with a cold head. Don't want to rush it. Leaving office now.

Thanks again.
Give this a try:

<!-- m --><a class="postlink" href=""></a><!-- m -->
Good and bad news... afterall... good news!

The contact ID field is now recognized by the CRM Field column, however instead of merging the records corebos is actually creating new ones. Yes I made sure to select the duplicate checkbox and select the "merge" option. I've tried it twice and each time the records are created instead of being merged.

EDIT: I figured out why it does this. When importing I was actually choosing ISO-8859-1 as the encoding (as for some reason using UTF-8 screws up special characters). I also chose several fields for identification namely: contact ID, first name and last names. I beleive that for the first and last names Corebos was interpreting the data as if it was different (due to the encoding) thus creating new records instead of merging them.

I have actually found a way to resolved this and also keeping the ISO-8859-1 encoding . It's by ONLY using the Contact ID as identifier in Step 3.

All contacts are now merged. Thanks Joe.
I'm glad you got it working, but I have to warn you: you MUST be using UTF8, ISO is obsolete, the future is UTF8 and has been for some time now. If it isn't working for you it is probably because you have incorrect set $default_charset in and/or your database codification is not set to UTF8.

In short: make you use UTF8 everywhere
The file states $default_charset = 'UTF-8';

However as exlained before when I export records with special characters those characters end up being scewed up. Perhaps due to the fact that when I imported the database the first time, the csv file was not encoded in UTF-8, I chose ISO instead.

What would you recommend to do to convert the whole database back to UTF-8? If that is possible would I end up needing to correct manually those records with special characters?

Forum Jump:

Users browsing this thread: 1 Guest(s)