Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[ solved ] Error on tried import comments
When I tried impor comments, system shows error at created cbCalendar db

At log
2018-07-23T18:24:40+00:00 DEBUG index Prepared sql query parameters : [110665]
2018-07-23T18:24:40+00:00 DEBUG index Prepared sql query being executed : INSERT INTO vtiger_activity_reminder_popup (semodule, recordid, date_start, time_start, status) VALUES (?,?,?,?,0)
2018-07-23T18:24:40+00:00 DEBUG index Prepared sql query parameters : [Calendar,110665,????,]
2018-07-23T18:24:40+00:00 INFO  VT PearDatabase ->ADODB error  Query Failed:INSERT INTO vtiger_activity_reminder_popup (semodule, recordid, date_start, time_start, status) VALUES (?,?,?,?,0)::->[1048]Column 'time_start' cannot be null
2018-07-23T18:24:40+00:00 INFO  VT PearDatabase ->TRANS Rolled Back
2018-07-23T18:24:40+00:00 INFO  VT PearDatabase ->TRANS Completed
2018-07-23T18:24:40+00:00 INFO  VT PearDatabase ->TRANS saveentity ends
eCRM Web
Can you give us an example of the columns you have in your import data?
As Guido1982 says we would need an example of the import file to be able to help,
thank you.

eCRM Web
My Portugese isn't that good, but it seems you do have the column time_start (Data do Evento)? Did you map the correct date to the correct field when you import? And did you check your entire import file for missing, or badly formed fields in that column? For instance, is there a field that is formatted '27-07-2018' while the rest is formatted '2018-07-27'? Or maybe there is something completely different in one of the fields in that column?

You said you are importing comments, but to which module are the comments related?
Hi Guido1982

Thanks for your reply

First I try send comments to Service Contracts with a trip Jos says, but not working for me ( Include a ServiceContracts:::Sadfullname) ) .. system always created a new Service Contracts

In this way, a setting a full name in related to, and system found a contacts correctly

There no time start because is not a mandatory field in Comments

I dont inderstand why system try create a cbcalendar event ?? Because I import comments not calandar events ...
eCRM Web
I'm not sure I follow you, you are using the normal import mechanism right? You should be able to indicate which fields you want to use for comparison/duplicate detection when you do step 3 of the import. If you have a column with the Service Contract no., use that and select merge. Make sure your column headings match the field label in the Service Contract no. exactly.

Secondly, comments are not a normal module. You may still need to set a column for 'time start' and populate it with some date/time. The SQL is failing because it's trying to set the time_start column but you haven't provided one.

The cbcalendar module may be pulled in because the calendar is trying to keep track of all modules that have some sort of date field, to be able to show that in the calendar, but I'm not sure about that.
please add a few rows of data, I cannot get an idea of the import without them.
just to make sure: you are importing in the ModComments module, right?
I say it because the CSV headers have other information.....
I test again :

if csv has Contacts::::Name - system try found a contact
If csv has only a name , system try insert on cbCalendar

Probably this causes occurs a mensagem cbCalendar error, when I try import my older CSV
eCRM Web
I understand that you are importing in the ModComments module. ModComments records have a "Related To" field which indicates to which exact record the comment belongs. When you import a "Related To" field like this, that has many possible modules you must indicate the module you are relating with. For example, you can have a comment related to a Lead or to a contact or to an account...

When you put in the column of the CSV for this field: "Joe Bordes"

The application has no information on where it has to search for this string, so it just picks the first module it can find and relates it there, after all, if you don't tell it what to do, then it does what it can.

Is that your problem?

I'd say this is explained in the wiki.....

Forum Jump:

Users browsing this thread: 2 Guest(s)