Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Timezone- scheduled reports
#1
How I set correctly a timezone for my installation

My question is a time I setting in scheduled reported not is correctly for my timezone

Example

Follow Up Atrasado - 2019-05-15 04:05:05 (UTC)

I think is necessary change UTC for America Sao Paulo

I can do that in config.inc.php ?
Ranieri
eCRM Web
Reply
#2
if you have already created tasks you cannot modify the value in the config.inc.php file

If you need the scheduled report at another time you will have to look at the code that sends it out to see how the value is caculated
Joe
TSolucio
Reply
#3
In fact, my problem is, for example

I sched report for 02:00 and system sent in another hour ...
Ranieri
eCRM Web
Reply
#4
make sure you are running the scheduled report task more or less at 2:00
Joe
TSolucio
Reply
#5
my cronn task executes a vtigercon every 15 minutes

but report in sent more than a two hours late

if I execute the same report manually, your execution is less 5 minutes ...

not a big problem, but i wish know, is possible, sent a report in sched hours, because a user routine need this ...
Ranieri
eCRM Web
Reply
#6
the frequency with which you execute the scheduled report also must be taken into consideration.

Go to settings > scheduled tasks.

Let's suppose that you have the scheduled report configured to run every two hours and it runs ar 1:50, the next time the cron executes, at 2:05, the schedule report will still have to wait about two hours to be able to launch and send the pending report.
Joe
TSolucio
Reply
#7
Yes, but is setting for every 15 minutes, too

There any relation with the server timezone? Because my server is setting for America/Sao_Paulo and in coreBOS config is UTC

I setting my server in my timezone, because tasks in calendar uses a server time when user editing a appointments
Ranieri
eCRM Web
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)