Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
CentOS7 VM Corebos File Permissions
Hi All... Happy New Year!

I've been doing some testing using VMs and I ran into something rather strange this morning. I've got a CentOS 7 VM that I'm testing PHP7, Wordpress and Corebos on. I got the basic system config setup and started testing. Wordpress is doing fine. So, the next step was to grab a fresh copy of Corebos from GitHub and run the install. The weird thing I saw was this:

  1. Set file ownership and permissions for the CoreBOS installation (owner apache.apache): Dirs 755 and file perms are set to 644
  2. CoreBOS basic file perms same as those being used by Wordpress apps.
  3. CoreBOS basic file perms same as production server. 
  4. Apache service running as user apache and group apache.
So, I start the install, take care of the PHP requirements on the screen but the install screen is telling me that the file permissions aren't correct. It's telling me the files/directories aren't writable. these are the same permissions I'm using on the production server; also running CentOS 7, with one exception. The production server is running PHP 5.4.16.

Thinking this is a bit strange I chmod to 755 and then hit Check again, but it makes no difference. 

Any idea why it would be complaining about file permissions like this when the only difference between this VM and the production server is the installation/version of PHP?

I also tried setting everything to 777 and got the same results... very strange.

[i]If I could work while on horseback that's where I'd be doing it. There's nothing like riding... Gives new meaning to the phrase, ride to live... live to ride.[/i]

Messages In This Thread
CentOS7 VM Corebos File Permissions - mweaver - 01-01-2018, 03:53 AM

Forum Jump:

Users browsing this thread: 1 Guest(s)