Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Customer Portal Error
#1
This one has got me good and stumped. I've been all over this thing and can't find anything wrong in the setup or permissions. However, when a user attempts to log into the customer portal after submitting their credentials for login this is what shows on the screen:

*Please see image attached*


Attached Files Thumbnail(s)
   
Mark

If I could work while on horseback that's where I'd be doing it. There's nothing like riding... Gives new meaning to the phrase, ride to live... live to ride.
Reply
#2
UPDATE:

Performing some debugging I'm finding this in the ssl_log_error file:
[22/Jul/2019:10:48:48 -0400] "GET / HTTP/1.1" 302 -

[22/Jul/2019:10:48:48 -0400] "GET /site/login HTTP/1.1" 200 9576
[22/Jul/2019:10:48:58 -0400] "GET /webservice.php?&operation=getchallenge&username=portaluser HTTP/1.1" 200 109
[22/Jul/2019:10:48:57 -0400] "POST /index.php/site/login HTTP/1.1" 550 970
[22/Jul/2019:10:48:59 -0400] "GET /images/loginVtigerCRM.png HTTP/1.1" 302 -
[22/Jul/2019:10:48:59 -0400] "GET /site/login HTTP/1.1" 200 9576
[22/Jul/2019:10:49:12 -0400] "POST /index.php?module=Calendar&action=CalendarAjax&file=ActivityReminderCallbackAjax&ajax=true HTTP/1.1" 200 94

The highlighted text above is a bit perplexing. That path doesn't exist with the Customer Portal folder structure, so unless it's calling out to the CoreBOS install something is missing here. This is a fresh grab of the CP from git hub by the way. The perms for files and folders in coreboscp are 755 and the ownership is apache.apache.

I've double-checked the path in apache's configuration and it's correct, so I'm left scratching my head.
Mark

If I could work while on horseback that's where I'd be doing it. There's nothing like riding... Gives new meaning to the phrase, ride to live... live to ride.
Reply
#3
I suppose you have set these three variables correctly:

https://github.com/tsolucio/coreBOSCP/blob/master/protected/config/PortalConfig.php#L23
https://github.com/tsolucio/coreBOSCP/blob/master/protected/config/PortalConfig.php#L27
https://github.com/tsolucio/coreBOSCP/blob/master/protected/config/PortalConfig.php#L28
Joe
TSolucio
Reply
#4
Brand new fresh install. Downloaded zip from git hub. Copied to the web server, set ownership and permission (apache.apache - 644 on files 755 on directories), set the value for those three variables: same result.
Mark

If I could work while on horseback that's where I'd be doing it. There's nothing like riding... Gives new meaning to the phrase, ride to live... live to ride.
Reply
#5
there is a global variable that blocks webservice, is that defined?
Joe
TSolucio
Reply
#6
I don't believe so. the only CP global I have defined is this one:

Application_Customer_Portal_URL https://vtcp.compinfosystems.com:4443 Portal User yes yes
Mark

If I could work while on horseback that's where I'd be doing it. There's nothing like riding... Gives new meaning to the phrase, ride to live... live to ride.
Reply
#7
you are looking for the webservice URL: Webservice_Enabled
Joe
TSolucio
Reply
#8
found it and set as enabled.
Webservice_Enabled 1 Administrator yes yes

the following is still showing in ssl_access_log
"POST /index.php/site/login HTTP/1.1" 550 970

really has me scratching my head.
Mark

If I could work while on horseback that's where I'd be doing it. There's nothing like riding... Gives new meaning to the phrase, ride to live... live to ride.
Reply
#9
One of our team members recorded a session configuring the customer portal. He got stuck configuring the coreBOS URL putting the customer portal instead.
Have a look and see if it helps:

https://youtu.be/03kOfVyDDH0
Joe
TSolucio
Reply
#10
let us know how it goes
Joe
TSolucio
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)